IS-IS⑤エリア間ルーティング(IOS編)

■IS-IS エリア間ルーティングの基本設定
IOSはDefaultでL1/L2ルータとして動作するため、エリア境界のルータ(R2/R3)で明示的に
Config設定する必要はなし。R1/R4ではL1ルーターとして設定

L1ルータの設定は以下。
router isis
is-type level-1

■Configとトポロジーは以下のとおり。

■R1
interface Loopback0
ip address 1.1.1.1 255.255.255.255
ip router isis
!
interface Loopback6
no ip address
ipv6 address 1::1/128
ipv6 router isis
!
interface GigabitEthernet1/0
ip address 12.12.12.1 255.255.255.0
ip router isis
negotiation auto
ipv6 address 12::1/64
ipv6 router isis
!
interface GigabitEthernet2/0
no ip address
shutdown
negotiation auto
!
router isis
net 49.0000.0000.0001.0000.00
is-type level-1
metric-style wide

■R2
interface Loopback0
ip address 2.2.2.2 255.255.255.255
ip router isis
!
interface Loopback6
no ip address
ipv6 address 2::2/128
ipv6 router isis
!
interface GigabitEthernet1/0
ip address 12.12.12.2 255.255.255.0
ip router isis
negotiation auto
ipv6 address 12::2/64
ipv6 router isis
!
interface GigabitEthernet2/0
ip address 23.23.23.2 255.255.255.0
ip router isis
negotiation auto
ipv6 address 23::2/64
ipv6 router isis
!
router isis
net 49.0000.0000.0002.0000.00
metric-style wide

■R3
interface Loopback0
ip address 3.3.3.3 255.255.255.255
ip router isis
!
interface Loopback6
no ip address
ipv6 address 3::3/128
ipv6 router isis
!
interface GigabitEthernet1/0
ip address 23.23.23.3 255.255.255.0
ip router isis
negotiation auto
ipv6 address 23::3/64
ipv6 router isis
!
interface GigabitEthernet2/0
ip address 34.34.34.3 255.255.255.0
ip router isis
negotiation auto
ipv6 address 34::3/64
ipv6 router isis
!
router isis
net 49.0001.0000.0003.0000.00
metric-style wide

■R4
interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface Loopback6
no ip address
ipv6 address 4::4/128
!
interface GigabitEthernet1/0
ip address 34.34.34.4 255.255.255.0
ip router isis
negotiation auto
ipv6 address 34::4/64
ipv6 router isis
!
router isis
net 49.0001.0000.0004.0000.00
is-type level-1
metric-style wide

■Neighbor状態やRIBエントリーは以下のとおり
R1⇔R4間のルーティングはL2ルータからDGWを受信する。

■R1
R1#show clns neighbors detail
System Id Interface SNPA State Holdtime Type Protocol
R2 Gi1/0 ca02.3338.001c Up 7 L1 IS-IS
Area Address(es): 49.0000
IP Address(es): 12.12.12.2*
IPv6 Address(es): FE80::C802:33FF:FE38:1C
Uptime: 00:07:03
NSF capable
Interface name: GigabitEthernet1/0

R1#show ip route
i*L1 0.0.0.0/0 [115/10] via 12.12.12.2, 00:06:50, GigabitEthernet1/0
1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback0
2.0.0.0/32 is subnetted, 1 subnets
i L1 2.2.2.2 [115/20] via 12.12.12.2, 00:07:03, GigabitEthernet1/0
12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 12.12.12.0/24 is directly connected, GigabitEthernet1/0
L 12.12.12.1/32 is directly connected, GigabitEthernet1/0
23.0.0.0/24 is subnetted, 1 subnets
i L1 23.23.23.0 [115/20] via 12.12.12.2, 00:07:01, GigabitEthernet1/0

R1#show ipv6 route
I1 ::/0 [115/10]
via FE80::C802:33FF:FE38:1C, GigabitEthernet1/0

LC 1::1/128 [0/0]
via Loopback6, receive
I1 2::2/128 [115/20]
via FE80::C802:33FF:FE38:1C, GigabitEthernet1/0
C 12::/64 [0/0]
via GigabitEthernet1/0, directly connected
L 12::1/128 [0/0]
via GigabitEthernet1/0, receive
I1 23::/64 [115/20]
via FE80::C802:33FF:FE38:1C, GigabitEthernet1/0
L FF00::/8 [0/0]
via Null0, receive

■R2
R2#show clns neighbors detail
System Id Interface SNPA State Holdtime Type Protocol
R1 Gi1/0 ca01.4624.001c Up 24 L1 IS-IS
Area Address(es): 49.0000
IP Address(es): 12.12.12.1*
IPv6 Address(es): FE80::C801:46FF:FE24:1C
Uptime: 00:07:50
NSF capable
Interface name: GigabitEthernet1/0
R3 Gi2/0 ca03.3860.001c Up 7 L2 IS-IS
Area Address(es): 49.0001
IP Address(es): 23.23.23.3*
IPv6 Address(es): FE80::C803:38FF:FE60:1C
Uptime: 00:07:35
NSF capable
Interface name: GigabitEthernet2/0

R2#show ip route
1.0.0.0/32 is subnetted, 1 subnets
i L1 1.1.1.1 [115/20] via 12.12.12.1, 00:07:49, GigabitEthernet1/0
2.0.0.0/32 is subnetted, 1 subnets
C 2.2.2.2 is directly connected, Loopback0
3.0.0.0/32 is subnetted, 1 subnets
i L2 3.3.3.3 [115/20] via 23.23.23.3, 00:07:34, GigabitEthernet2/0
12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 12.12.12.0/24 is directly connected, GigabitEthernet1/0
L 12.12.12.2/32 is directly connected, GigabitEthernet1/0
23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 23.23.23.0/24 is directly connected, GigabitEthernet2/0
L 23.23.23.2/32 is directly connected, GigabitEthernet2/0
34.0.0.0/24 is subnetted, 1 subnets
i L2 34.34.34.0 [115/20] via 23.23.23.3, 00:07:34, GigabitEthernet2/0

R2#show ipv6 route
I1 1::1/128 [115/20]
via FE80::C801:46FF:FE24:1C, GigabitEthernet1/0
LC 2::2/128 [0/0]
via Loopback6, receive
I2 3::3/128 [115/20]
via FE80::C803:38FF:FE60:1C, GigabitEthernet2/0
C 12::/64 [0/0]
via GigabitEthernet1/0, directly connected
L 12::2/128 [0/0]
via GigabitEthernet1/0, receive
C 23::/64 [0/0]
via GigabitEthernet2/0, directly connected
L 23::2/128 [0/0]
via GigabitEthernet2/0, receive
I2 34::/64 [115/20]
via FE80::C803:38FF:FE60:1C, GigabitEthernet2/0
L FF00::/8 [0/0]
via Null0, receive

■R3
R3#show clns neighbors detail
System Id Interface SNPA State Holdtime Type Protocol
R2 Gi1/0 ca02.3338.0038 Up 23 L2 IS-IS
Area Address(es): 49.0000
IP Address(es): 23.23.23.2*
IPv6 Address(es): FE80::C802:33FF:FE38:38
Uptime: 00:07:55
NSF capable
Interface name: GigabitEthernet1/0
R4 Gi2/0 ca04.47f0.001c Up 9 L1 IS-IS
Area Address(es): 49.0001
IP Address(es): 34.34.34.4*
IPv6 Address(es): FE80::C804:47FF:FEF0:1C
Uptime: 00:08:19
NSF capable
Interface name: GigabitEthernet2/0

R3#show ip route
1.0.0.0/32 is subnetted, 1 subnets
i L2 1.1.1.1 [115/30] via 23.23.23.2, 00:01:10, GigabitEthernet1/0
2.0.0.0/32 is subnetted, 1 subnets
i L2 2.2.2.2 [115/20] via 23.23.23.2, 00:01:09, GigabitEthernet1/0
3.0.0.0/32 is subnetted, 1 subnets
C 3.3.3.3 is directly connected, Loopback0
12.0.0.0/24 is subnetted, 1 subnets
i L2 12.12.12.0 [115/20] via 23.23.23.2, 00:01:09, GigabitEthernet1/0
23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 23.23.23.0/24 is directly connected, GigabitEthernet1/0
L 23.23.23.3/32 is directly connected, GigabitEthernet1/0
34.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 34.34.34.0/24 is directly connected, GigabitEthernet2/0
L 34.34.34.3/32 is directly connected, GigabitEthernet2/0

R3#show ipv6 route
IPv6 Routing Table – default – 9 entries
I2 1::1/128 [115/30]
via FE80::C802:33FF:FE38:38, GigabitEthernet1/0
I2 2::2/128 [115/20]
via FE80::C802:33FF:FE38:38, GigabitEthernet1/0
LC 3::3/128 [0/0]
via Loopback6, receive
I2 12::/64 [115/20]
via FE80::C802:33FF:FE38:38, GigabitEthernet1/0
C 23::/64 [0/0]
via GigabitEthernet1/0, directly connected
L 23::3/128 [0/0]
via GigabitEthernet1/0, receive
C 34::/64 [0/0]
via GigabitEthernet2/0, directly connected
L 34::3/128 [0/0]
via GigabitEthernet2/0, receive
L FF00::/8 [0/0]
via Null0, receive

■R4
R4#show clns neighbors detail
System Id Interface SNPA State Holdtime Type Protocol
R3 Gi1/0 ca03.3860.0038 Up 26 L1 IS-IS
Area Address(es): 49.0001
IP Address(es): 34.34.34.3*
IPv6 Address(es): FE80::C803:38FF:FE60:38
Uptime: 00:08:22
NSF capable
Interface name: GigabitEthernet1/0

R4#show ip route
i*L1 0.0.0.0/0 [115/10] via 34.34.34.3, 00:01:32, GigabitEthernet1/0
3.0.0.0/32 is subnetted, 1 subnets
i L1 3.3.3.3 [115/20] via 34.34.34.3, 00:01:32, GigabitEthernet1/0
4.0.0.0/32 is subnetted, 1 subnets
C 4.4.4.4 is directly connected, Loopback0
23.0.0.0/24 is subnetted, 1 subnets
i L1 23.23.23.0 [115/20] via 34.34.34.3, 00:01:32, GigabitEthernet1/0
34.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 34.34.34.0/24 is directly connected, GigabitEthernet1/0
L 34.34.34.4/32 is directly connected, GigabitEthernet1/0

R4#show ipv6 route
I1 ::/0 [115/10]
via FE80::C803:38FF:FE60:38, GigabitEthernet1/0

I1 3::3/128 [115/20]
via FE80::C803:38FF:FE60:38, GigabitEthernet1/0
LC 4::4/128 [0/0]
via Loopback6, receive
I1 23::/64 [115/20]
via FE80::C803:38FF:FE60:38, GigabitEthernet1/0
C 34::/64 [0/0]
via GigabitEthernet1/0, directly connected
L 34::4/128 [0/0]
via GigabitEthernet1/0, receive
L FF00::/8 [0/0]
via Null0, receive