■IS-IS のパスセレクションについて
IOS XRでは以下の設定する。
————————————-
router isis 1
interface GigabitEthernet0/0/0/1
address-family ipv4 unicast
metric 1000
!
address-family ipv6 unicast
metric 1000
————————————-
IOSについては以下の設定する。
————————————-
interface FastEthernet0/0
isis metric 1000
————————————-
■Configとトポロジーについては以下(Configは設定後)
■XR1
XR1#show running-config
interface Loopback0
ipv4 address 1.1.1.1 255.255.255.255
!
interface Loopback6
ipv6 address 1::1/128
!
!
interface GigabitEthernet0/0/0/0
ipv4 address 12.12.12.1 255.255.255.0
ipv6 address 12::1/64
!
interface GigabitEthernet0/0/0/1
ipv4 address 13.13.13.1 255.255.255.0
ipv6 address 13::1/64
!
router isis 1
is-type level-1
net 49.0000.0000.0001.0000.00
address-family ipv4 unicast
metric-style wide
!
address-family ipv6 unicast
metric-style wide
!
interface Loopback0
address-family ipv4 unicast
!
!
interface Loopback6
address-family ipv6 unicast
!
!
interface GigabitEthernet0/0/0/0
address-family ipv4 unicast
!
address-family ipv6 unicast
!
!
interface GigabitEthernet0/0/0/1
address-family ipv4 unicast
metric 1000
!
address-family ipv6 unicast
metric 1000
!
end
■R3
R3#show running-config
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
ip router isis
!
interface Loopback6
no ip address
ipv6 address 3::3/128
ipv6 router isis
!
interface FastEthernet0/0
ip address 13.13.13.3 255.255.255.0
ip router isis
duplex full
ipv6 address 13::3/64
ipv6 router isis
isis metric 1000
!
interface GigabitEthernet1/0
ip address 23.23.23.3 255.255.255.0
ip router isis
negotiation auto
ipv6 address 23::3/64
ipv6 router isis
!
interface GigabitEthernet2/0
ip address 34.34.34.3 255.255.255.0
ip router isis
negotiation auto
ipv6 address 34::3/64
ipv6 router isis
!
router isis
net 49.0000.0000.0003.0000.00
is-type level-1
metric-style wide
!
address-family ipv6
multi-topology
exit-address-family
!
end
■RIBエントリーは以下のとおりになる(設定前後比較)
※設定前
■XR1
XR1#show route ipv4 unicast
L 1.1.1.1/32 is directly connected, 14:37:45, Loopback0
i L1 2.2.2.2/32 [115/20] via 12.12.12.2, 00:08:53, GigabitEthernet0/0/0/0
i L1 3.3.3.3/32 [115/20] via 13.13.13.3, 00:02:31, GigabitEthernet0/0/0/1
i L1 4.4.4.4/32 [115/30] via 13.13.13.3, 00:02:31, GigabitEthernet0/0/0/1
C 12.12.12.0/24 is directly connected, 14:37:45, GigabitEthernet0/0/0/0
L 12.12.12.1/32 is directly connected, 14:37:45, GigabitEthernet0/0/0/0
C 13.13.13.0/24 is directly connected, 14:31:25, GigabitEthernet0/0/0/1
L 13.13.13.1/32 is directly connected, 14:31:25, GigabitEthernet0/0/0/1
i L1 23.23.23.0/24 [115/20] via 12.12.12.2, 00:02:31, GigabitEthernet0/0/0/0
[115/20] via 13.13.13.3, 00:02:31, GigabitEthernet0/0/0/1
i L1 34.34.34.0/24 [115/20] via 13.13.13.3, 00:02:31, GigabitEthernet0/0/0/1
XR1#show route ipv6 unicast
L 1::1/128 is directly connected,
17:46:59, Loopback6
i L1 2::2/128
[115/20] via fe80::a00:27ff:fee2:1a7c, 03:18:07, GigabitEthernet0/0/0/0
i L1 3::3/128
[115/20] via fe80::c803:38ff:fe60:0, 00:04:25, GigabitEthernet0/0/0/1
i L1 4::4/128
[115/30] via fe80::c803:38ff:fe60:0, 00:03:21, GigabitEthernet0/0/0/1
C 12::/64 is directly connected,
17:46:59, GigabitEthernet0/0/0/0
L 12::1/128 is directly connected,
17:46:59, GigabitEthernet0/0/0/0
C 13::/64 is directly connected,
17:40:38, GigabitEthernet0/0/0/1
L 13::1/128 is directly connected,
17:40:38, GigabitEthernet0/0/0/1
i L1 23::/64
[115/20] via fe80::a00:27ff:fee2:1a7c, 00:04:25, GigabitEthernet0/0/0/0
[115/20] via fe80::c803:38ff:fe60:0, 00:04:25, GigabitEthernet0/0/0/1
i L1 34::/64
[115/20] via fe80::c803:38ff:fe60:0, 00:04:25, GigabitEthernet0/0/0/1
■R3
R3#show ip route
1.0.0.0/32 is subnetted, 1 subnets
i L1 1.1.1.1 [115/20] via 13.13.13.1, 02:43:27, FastEthernet0/0
2.0.0.0/32 is subnetted, 1 subnets
i L1 2.2.2.2 [115/20] via 23.23.23.2, 02:50:06, GigabitEthernet1/0
3.0.0.0/32 is subnetted, 1 subnets
C 3.3.3.3 is directly connected, Loopback0
4.0.0.0/32 is subnetted, 1 subnets
i L1 4.4.4.4 [115/20] via 34.34.34.4, 02:54:45, GigabitEthernet2/0
12.0.0.0/24 is subnetted, 1 subnets
i L1 12.12.12.0 [115/20] via 23.23.23.2, 02:43:27, GigabitEthernet1/0
[115/20] via 13.13.13.1, 02:43:27, FastEthernet0/0
13.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 13.13.13.0/24 is directly connected, FastEthernet0/0
L 13.13.13.3/32 is directly connected, FastEthernet0/0
23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 23.23.23.0/24 is directly connected, GigabitEthernet1/0
L 23.23.23.3/32 is directly connected, GigabitEthernet1/0
34.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 34.34.34.0/24 is directly connected, GigabitEthernet2/0
L 34.34.34.3/32 is directly connected, GigabitEthernet2/0
R3#show ipv6 route
I1 1::1/128 [115/20]
via FE80::A00:27FF:FE24:287D, FastEthernet0/0
I1 2::2/128 [115/20]
via FE80::A00:27FF:FE2A:972D, GigabitEthernet1/0
LC 3::3/128 [0/0]
via Loopback6, receive
I1 4::4/128 [115/20]
via FE80::C804:47FF:FEF0:1C, GigabitEthernet2/0
I1 12::/64 [115/20]
via FE80::A00:27FF:FE24:287D, FastEthernet0/0
via FE80::A00:27FF:FE2A:972D, GigabitEthernet1/0
C 13::/64 [0/0]
via FastEthernet0/0, directly connected
L 13::3/128 [0/0]
via FastEthernet0/0, receive
C 23::/64 [0/0]
via GigabitEthernet1/0, directly connected
L 23::3/128 [0/0]
via GigabitEthernet1/0, receive
C 34::/64 [0/0]
via GigabitEthernet2/0, directly connected
L 34::3/128 [0/0]
via GigabitEthernet2/0, receive
L FF00::/8 [0/0]
via Null0, receive
※設定後
■XR1
XR1#show route ipv4 unicast
L 1.1.1.1/32 is directly connected, 17:53:06, Loopback0
i L1 2.2.2.2/32 [115/20] via 12.12.12.2, 03:24:14, GigabitEthernet0/0/0/0
i L1 3.3.3.3/32 [115/30] via 12.12.12.2, 00:00:47, GigabitEthernet0/0/0/0
i L1 4.4.4.4/32 [115/40] via 12.12.12.2, 00:00:47, GigabitEthernet0/0/0/0
C 12.12.12.0/24 is directly connected, 17:53:06, GigabitEthernet0/0/0/0
L 12.12.12.1/32 is directly connected, 17:53:06, GigabitEthernet0/0/0/0
C 13.13.13.0/24 is directly connected, 17:46:46, GigabitEthernet0/0/0/1
L 13.13.13.1/32 is directly connected, 17:46:46, GigabitEthernet0/0/0/1
i L1 23.23.23.0/24 [115/20] via 12.12.12.2, 00:00:47, GigabitEthernet0/0/0/0
i L1 34.34.34.0/24 [115/30] via 12.12.12.2, 00:00:47, GigabitEthernet0/0/0/0
XR1#show route ipv6 unicast
L 1::1/128 is directly connected,
17:53:28, Loopback6
i L1 2::2/128
[115/20] via fe80::a00:27ff:fee2:1a7c, 03:24:36, GigabitEthernet0/0/0/0
i L1 3::3/128
[115/30] via fe80::a00:27ff:fee2:1a7c, 00:01:09, GigabitEthernet0/0/0/0
i L1 4::4/128
[115/40] via fe80::a00:27ff:fee2:1a7c, 00:01:09, GigabitEthernet0/0/0/0
C 12::/64 is directly connected,
17:53:27, GigabitEthernet0/0/0/0
L 12::1/128 is directly connected,
17:53:27, GigabitEthernet0/0/0/0
C 13::/64 is directly connected,
17:47:07, GigabitEthernet0/0/0/1
L 13::1/128 is directly connected,
17:47:07, GigabitEthernet0/0/0/1
i L1 23::/64
[115/20] via fe80::a00:27ff:fee2:1a7c, 00:01:09, GigabitEthernet0/0/0/0
i L1 34::/64
[115/30] via fe80::a00:27ff:fee2:1a7c, 00:01:09, GigabitEthernet0/0/0/0
■R3
R3#show ip route
1.0.0.0/32 is subnetted, 1 subnets
i L1 1.1.1.1 [115/30] via 23.23.23.2, 00:01:55, GigabitEthernet1/0
2.0.0.0/32 is subnetted, 1 subnets
i L1 2.2.2.2 [115/20] via 23.23.23.2, 02:56:32, GigabitEthernet1/0
3.0.0.0/32 is subnetted, 1 subnets
C 3.3.3.3 is directly connected, Loopback0
4.0.0.0/32 is subnetted, 1 subnets
i L1 4.4.4.4 [115/20] via 34.34.34.4, 03:01:11, GigabitEthernet2/0
12.0.0.0/24 is subnetted, 1 subnets
i L1 12.12.12.0 [115/20] via 23.23.23.2, 00:01:55, GigabitEthernet1/0
13.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 13.13.13.0/24 is directly connected, FastEthernet0/0
L 13.13.13.3/32 is directly connected, FastEthernet0/0
23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 23.23.23.0/24 is directly connected, GigabitEthernet1/0
L 23.23.23.3/32 is directly connected, GigabitEthernet1/0
34.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 34.34.34.0/24 is directly connected, GigabitEthernet2/0
L 34.34.34.3/32 is directly connected, GigabitEthernet2/0
R3#show ipv6 route
I1 1::1/128 [115/30]
via 23.23.23.2, 00:01:55, GigabitEthernet1/0
I1 2::2/128 [115/20]
via FE80::A00:27FF:FE2A:972D, GigabitEthernet1/0
LC 3::3/128 [0/0]
via Loopback6, receive
I1 4::4/128 [115/20]
via FE80::C804:47FF:FEF0:1C, GigabitEthernet2/0
I1 12::/64 [115/20]
via FE80::A00:27FF:FE24:287D, FastEthernet0/0
via FE80::A00:27FF:FE2A:972D, GigabitEthernet1/0
C 13::/64 [0/0]
via FastEthernet0/0, directly connected
L 13::3/128 [0/0]
via FastEthernet0/0, receive
C 23::/64 [0/0]
via GigabitEthernet1/0, directly connected
L 23::3/128 [0/0]
via GigabitEthernet1/0, receive
C 34::/64 [0/0]
via GigabitEthernet2/0, directly connected
L 34::3/128 [0/0]
via GigabitEthernet2/0, receive
L FF00::/8 [0/0]
via Null0, receive